Microsoft

System Center Configuration Manager Feedback

Suggestion box powered by UserVoice

How can we improve Configuration Manager?

Change the default timeout for feature updates, when feature updates timeout they should fail and stop.

The feature updates in our environment always time out on the older machines with mechanical drives as they are slow to update. It would be helpful if the timeout was set to a lot more than 1 hour by default. Secondly when it does time out it would be helpful if it failed the deployment instead of sitting in software center saying it's installing indefinitely. The only way I've been able to do this is to delete the client from SCCM and re-install the agent on the client machine. Distribution of feature updates through SCCM needs a lot of work.

30 votes
Vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

3 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    This is even more of an issue because every time a new update is reissued (has happened twice with 1809 now), the new update has the default of 60 minutes timeout set again. So we constantly have to keep an eye on the new releases of the same feature updates and increase the timeouts manually on each one.

    With more of the install moving into the pre and post reboot phases, 60 minutes is far, far to short, even on very fast hardware and SSD.

  • Ben Watt commented  ·   ·  Flag as inappropriate

    Part of the problem is that more and more of the install is now done before restart, particularly from 1803 onwards, so 60 minutes is rarely going to be enough time now, whereas in the past it would have been.

    At the very least, having it stop saying "Installing" when it hits the timeout would be a step in the right direction!

  • Ronni Pedersen commented  ·   ·  Flag as inappropriate

    I saw the same behavior today with Windows 10 1809. All test clients failed to upgrade.
    We changed the value from 60 to 180, and then it worked.

    180 minutes may not even be enough to cover 100% of the cases. Poorly-performing test VMs is the worst.

Feedback and Knowledge Base