System Center Configuration Manager Feedback

Suggestion box powered by UserVoice

How can we improve Configuration Manager?

Remote Control Disconnects When Adding a Printer in Windows 10

When adding a printer on a Windows 10 client through remote control, the session gets disconnected.

It looks like others have encountered the same issue:

79 votes
Sign in
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
Todd Weiser shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Reading through the comments in this it appears that this is a bug report.

Additionally, it appears that this may not be specifically a problem with Configuration Manager, rather it’s an issue with a system-level component changing state and dropping the remote control session. Does this reproduce when using a vanilla RDP connection?

I would recommend filing a bug against Windows through Feedback Hub or contacting Support to provide more in-depth troubleshooting on this.


Sign in
Sign in with: Facebook Google
Signed in as (Sign out)
  • Jen commented  ·   ·  Flag as inappropriate

    Do we know if a bug report has been submitted for this yet? I'm trying to find more information on this, but this thread appears to be it.

  • Matt commented  ·   ·  Flag as inappropriate

    Adam -"Does this reproduce when using a vanilla RDP connection?"

    It does happen from my testing. RDP disconnects for a brief second but reconnects. This is the different with the remote control where it will disconnect you and not reconnect the session. It locks the screen on the user.

  • Anonymous commented  ·   ·  Flag as inappropriate

    We also have this problem. Only appears to affect windows 10 laptops (with wifi). Please fix

  • Neemobeer commented  ·   ·  Flag as inappropriate

    I did a NDIS trace and found that the Microsoft Wi-Fi Virtual Adapter filter driver resets when trying to add a printer. This causes the connection handle to become invalid and closes the connection. A workaround is to disable the MWDVA from powershell with the following.

    Get-PnpDevice -FriendlyName "Microsoft Wi-Fi*Virtual*" | Disable-PnpDevice

    No reboot is required. This will disable MIRACAST, but otherwise doesn't affect anything.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Same problem here, Windows 10 1803 - SCCM 1802. Also in another environment with SCCM 1806.

  • Andre commented  ·   ·  Flag as inappropriate

    I tried Windows 10 LTSB build 10240 (2015) too and even there is this same problem. Most our pc's are running on 1607 LTSB build.
    But in other threads, people say they are using Current Branch versions, and problem exists there too...

  • Andre commented  ·   ·  Flag as inappropriate

    I have looked more into this and looks like this problem is only with pc's where wifi card and MS Wi-Fi Direct Virtual adapter is. Desktop pc's what we have, doesn't seem to have this problem (at least i haven't found one yet). Doesn't matter what wifi card model is...

    And even in Technet there is a thread about it from 2016...

    It seems that if i run PS command: "Get-NetAdapter -InterfaceDescription "Microsoft Wi-Fi Direct Virtual*" | Disable-NetAdapter -Confirm:$false", then i can add printer, click finish. What then happens - everything works and feels like problem is gone but really it takes about 20-30 seconds and bamm same thing - disconnect and client pc user gets locked.

  • Andre commented  ·   ·  Flag as inappropriate

    We have exactly same problem. CmRcService.log tells me this:
    Media disconnect occurred at MSNdis_StatusMediaDisconnect via class Microsoft Wi-Fi Direct Virtual Adapter #2
    A connector error has occurred. (OnConnectorError).
    An existing connection was forcibly closed by the remote host. (Error: 80072746; Source: Windows)
    Locking Desktop... Detected severed network connection or abnormal disconnection of the viewer.
    Disconnecting the connection.
    An existing connection was forcibly closed by the remote host. (Error: 80072746; Source: Windows)
    === The remote control session has been terminated
    The remote control viewer has disconnected from the session (OnViewerDisconnected)
    Remote control session lasted 0 minutes. CmRcService 14.05.2018 11:55.35 9056 (0x2360)

    This has been a problem some time now. This happens only on Windows 10 pc's, Win7 is good. We use 1607 version from Windows 10 LTSB.

    We need a solution for this!

Feedback and Knowledge Base