Microsoft

System Center Configuration Manager Feedback

Suggestion box powered by UserVoice

How can we improve Configuration Manager?

FSP configuration on Clients

I configured a Fallback Status Point on a test site and noticed illogical behavior.
IntranetHostName Under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCM\FSP gets the new FSP, but Hostname doesn’t get this value. This is noted in LocationService.log every 25 hours ‘Updated FSP … from AD to local. When I execute ccmsetup.exe on a machine both values get the new FSP.

FSPStateMessage.log contains errors when HostName is not configured:
Failed to create HTTP connection
[CCMHTTP] ERROR: URL=HTTP:///SMS_FSP/.sms_fsp, Port=80, Options=480, Code=12005, Text=ERROR_WINHTTP_INVALID_URL
Successfully queued event on HTTP/HTTPS failure for server '[]'.

I presume the next message means the FSP Message got send with the InternalHostname afterwards.
State message with TopicType 1000 and TopicId CCM Framework Communication State has been sent to the FSP
These Errors went away when I changed the HostName Value.

The FSP was configured as Intranet Only. This could explain why only the InternalHostName is set. But not why ccmsetup will still set both. And I think Hostname should be ignored when it’s empty.
The current behavior creates the impression something is not working when you look at FSPStateMessage.log.

I will change the HostName value in the registry to avoid these errors in the logs. This will also happen when ccmsetup is executed again on these clients.

Could you consider to change the behavior.
- Set Hostname consistently
- Don't try to contact Hostname when the value is empty.

Currently running CM1702+kb4019926+kb4038659

3 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Koenraad Rens shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base