Microsoft

System Center Configuration Manager Feedback

Suggestion box powered by UserVoice

How can we improve Configuration Manager?

Remote tools - client setting to change client service to Automatic startup

One of the biggest issues I hear with the Remote Tools is that when you restart a machine it takes a couple of minutes before you can remote control it again. This is due to the delayed start of the service. I assume that this cannot be changed per default but give us the option using a client setting to change it to Automatic instead of using a GPO would be really sweet!
This is very similar to the following feedback item. https://configurationmanager.uservoice.com/forums/300492-ideas/suggestions/8471107-fix-remote-control-bug-after-client-reboot#comments

112 votes
Vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
Jörgen Nilsson shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

11 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    I can see that only new installatio gets the service to be auto. Why only new ?

  • Bob Bilek commented  ·   ·  Flag as inappropriate

    Please explain where this is fixed. We just updated to SCCM 1902. I'm looking at a client whose version is 5.00.8790.1007. The SMS Agent Host service is still Automatic (Delayed Start).

  • Henrik commented  ·   ·  Flag as inappropriate

    Hey. We just upgraded to sccm 1810. It is till set do delayed start. Will it only happen for new installation ?

  • William commented  ·   ·  Flag as inappropriate

    I have created a frontend for SCCM with a button to initiate the services on the remote system.
    This stops the waiting. It also remembers all devices accessed. Anyone interested?

  • Steve Arnold commented  ·   ·  Flag as inappropriate

    I vote for a change to this issue to become a default. RDP or even an installed VNC will react sooner than the SCCM client. It is very frustrating with a user on the phone waiting too.

  • Jörgen Nilsson commented  ·   ·  Flag as inappropriate

    To clarify, the title is somewhat wrong, Change the Remote tools startup setting in Client Settings.

  • Leif commented  ·   ·  Flag as inappropriate

    The service by default it set to Automatic Start (Delayed), we used a Group Policy and set the service to Automatic Start and the issue is now fixed.

  • Cristopher commented  ·   ·  Flag as inappropriate

    We are well familiar with this behavior and it can sometimes be upwards of 5 minutes to get back into a remote control session. I'm not sure I would call it a bug though because the services are set to Automatic (delayed start). I'd imagine that the SCCM client proper needs to be fully initialized before the remote control component can be utilized.

    Luckily, with new hardware utilizing SSDs and gigabit network connections, this issue becomes less and less of a problem for our technicians as time goes by.

  • Steve Whitcher commented  ·   ·  Flag as inappropriate

    I don't know if the root cause is the same, but it also takes a very long time to reconnect after the client disconnects/reconnects to the network.

  • teammala commented  ·   ·  Flag as inappropriate

    Please fix remote control bug that prevents remote control after client is rebooted. Currently you have to wait long time after client reboot to remote control again or have to disconnect remote control before client gets rebooted.

Feedback and Knowledge Base