Microsoft

System Center Configuration Manager Feedback

Suggestion box powered by UserVoice

How can we improve Configuration Manager?

Ability to specify a Software Update as a dependency

I'd like the ability to choose a Software Update as a dependency for applications. Instead of creating .NET 4.6.1 as an Application, specify the Software Update for it that is already in place.

3 votes
Vote
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
You have left! (?) (thinking…)
Adam shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...
  • bdam commented  ·   ·  Flag as inappropriate

    The difficulty I see is that those dependencies would become highly OS specific. Updates sometimes apply to specific OS's and then get superseded. So you'd need to constantly monitor and understand the changing landscape. With MS's changes to update rollups I think this becomes even worse.

    Your example of .NET 4.6.1 show another issue. Only Windows 7 and Server 2012 R2 have updates that install .NET 4.6.1. There is no update for other OSs and in some cases (Win 10 1511+) the update is part of the OS. The .Net updates are now rollups and are superseding the previous month's. So you're going to have to create some pretty convoluted dependencies to cover .NET in terms of what updates are installed.

Feedback and Knowledge Base